Multi-Factor Authentication: Troubleshoot MFA Setup
Summary
When users are trying to login to myprofile.usask.ca or paws.usask.ca they are getting redirected to enroll in MFA and update recovery options screens. Users may use these step-by-step instructions to fix this issue.
Body
Cause
You might be getting redirected to the Update Recovery Options page after entering credentials on Paws / MyProfile.
Resolution
- Complete Recovery Options. Click Next.
- Option 1: Email
- Option 2: Recovery Mobile Phone Number
- Option 3: Security Questions
- Click Update MFA Options.

- After selecting Update MFA Options follow how to set up the preferred method of MFA visit Multi-Factor Authentication: Enroll MFA on USask Account
- You might get redirected to the password recovery methods screen one last time after entering credentials on Paws / MyProfile. Click Next.
- You will be able to see the following screen with Reload button and Status: PENDING.

- Click Reload to change the Status to VERIFIED.

- Once the status shows VERIFIED, you will be able to log in to MyProfile.
Always setup TWO Methods of MFA authentication. This way you always have a backup MFA method should one change or not be available momentarily.
Additional Information: Video showing how to Setup MFA
Details
Details
Article ID:
589
Created
Tue 5/28/24 5:51 PM
Modified
Tue 3/3/26 2:27 PM